Russian Qt Forum
Январь 31, 2023, 00:08 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: [1]   Вниз
  Печать  
Автор Тема: Добавить Android API level 23 к установленному 15  (Прочитано 5165 раз)
Гурман
Гуру общения
******
Offline Offline

Сообщений: 1442

Qt 2.2, 3.3, 4.5, 4,7, 4.8, 5.3, 5.6, 5.9, 5.12


Просмотр профиля
« : Июнь 05, 2017, 13:56 »

Создаю приложения для Android в Linux 14. Приложения собираются с API level 15 всё хорошо. Мне необходимо это сохранить. Но для создания нового приложения требуется API level 23. То есть, мне нужно сохранить возможность сборки с API level 15, и получить возможность сборки с API level 23. Как я устанавливал и настраивал всю эту мутоту, я уже точно не помню. По идее, должно быть достаточно в Android SDK Manager установить один пакет. Запускаю этот менеджер, он сам предлагает сделать апдейт Android SDK Tools 25.1.7, Android SDK Platform-tools 24, Android Support Repository, Google Repository. Вот тут мне уже не понятно - действительно ли необходимо обновлять все эти пакеты? Не потеряю я при этом возможность сборки с API level 15? Кто-нибудь работает на одной машине с двумя API разных версий? Какие есть подводные камни?

Заодно - везде, в том числе и на фирменном сайте Google, советуют для установки какого-то одного пакета использовать командную утилиту sdkmanager. Но у меня её почему-то нет, не нашёл в каталогах где установлен Android SDK.
Записан

2^7-1 == 127, задумайтесь...
kibsoft
Хакер
*****
Offline Offline

Сообщений: 625


Просмотр профиля WWW
« Ответ #1 : Июнь 05, 2017, 18:11 »

Обычно ставится последний API level через Android SDK Manager, а дальше в AndroidManifest.xml указывается последний API как target, а так же минимальный API (в вашем случае 15). Если не используется никаких новых возможностей из последних API, то на старых девайсах должно работать так же. Особых проблем с этим у меня не возникало, но я делал только проекты на Qt Quick и там минимальный API - 16. Пакеты все обычно обновляю, проблем не было. А у вас на виджетах проект?
Записан

http://kibsoft.ru - Download the Qt Media Encoding Library here

The apps that were written using QtMEL:
http://srecorder.com - Screen recording software
Гурман
Гуру общения
******
Offline Offline

Сообщений: 1442

Qt 2.2, 3.3, 4.5, 4,7, 4.8, 5.3, 5.6, 5.9, 5.12


Просмотр профиля
« Ответ #2 : Июнь 05, 2017, 19:45 »

Да, проект на виджетах. У меня был развёрнут API 15, в проектах было target==minimum==15. И в готовых проектах так и должно остаться. В новых должно быть target==23, minimum==15. Установил через SDK Manager соответствующие модули для API 23, но пока ещё не начинал собирать. Не знаю - не будет ли проблем с компилятором (GCC 4.9), установленным NDK (r12b) и его отладчиком. Помню, что когда в первый раз устанавливал, вроде были какие-то несовместимости пакетов, не всё сразу заработало.
Записан

2^7-1 == 127, задумайтесь...
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  


Страница сгенерирована за 0.045 секунд. Запросов: 22.