Russian Qt Forum
Май 24, 2017, 16:26 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: [1]   Вниз
  Печать  
Автор Тема: Plugin для Qt Creator 4.2.1  (Прочитано 240 раз)
GraninDm
Чайник
*
Offline Offline

Сообщений: 78


Просмотр профиля
« : Февраль 16, 2017, 15:55 »

Добрый день!

Сегодня установил Qt 5.8.
Пытался сделать плагин для Creator

Скачал исходники 4.2.1
Создаю плагин компилирую, получаю сообщение
:-1: ошибка: cannot find -lCored4
:-1: ошибка: cannot find -lAggregationd4
:-1: ошибка: cannot find -lExtensionSystemd4
:-1: ошибка: cannot find -lUtilsd4
collect2.exe:-1: ошибка: error: ld returned 1 exit status

Компилирую Qt Creator.
Все компилируется, но при запуске вываливается ошибка и ничего не происходит
Получаю, то, что на скриншоте


Думаю, пусть не запускается, хотя бы докомпилируется до конца
Компилирую... То же самое.

Смотрю makefile/debug
А там
LIBS        =        -LC:\Qt\Qt5.8.0\Tools\QtCreator\bin\lib\qtcreator -LC:\Qt\Qt5.8.0\Tools\QtCreator\bin\lib\qtcreator\plugins -lCored4 -lAggregationd4 -lExtensionSystemd4 -lUtilsd4 -LC:\Users\granin_db\AppData\Local\QtProject\qtcreator\plugins\4.2.1 -LC:\Qt\Qt5.8.0\5.8\mingw53_32\lib C:\Qt\Qt5.8.0\5.8\mingw53_32\lib\libQt5Widgetsd.a C:\Qt\Qt5.8.0\5.8\mingw53_32\lib\libQt5Guid.a C:\Qt\Qt5.8.0\5.8\mingw53_32\lib\libQt5Testd.a C:\Qt\Qt5.8.0\5.8\mingw53_32\lib\libQt5Concurrentd.a C:\Qt\Qt5.8.0\5.8\mingw53_32\lib\libQt5Cored.a debug\PgConnectionManagerd_resource_res.o

Так вот этого каталога
C:\Qt\Qt5.8.0\Tools\QtCreator\bin\lib\qtcreator\plugins
нет
Зато есть
C:\Qt\Qt5.8.0\Tools\QtCreator\lib\qtcreator\plugins
И там лежит qcord4 (не отладочная версия)

Скопировал в C:\Qt\Qt5.8.0\Tools\QtCreator\ весь каталог lib (для проверки)

Откомпилировал в release, соответственно qcorе4 нашлась
Осталось
:-1: ошибка: cannot find -lAggregation4
:-1: ошибка: cannot find -lExtensionSystem4
:-1: ошибка: cannot find -lUtils4
collect2.exe:-1: ошибка: error: ld returned 1 exit status

Aggregation4 лежит в C:\Qt\Qt5.8.0\Tools\QtCreator\bin

Добавляю в qtcreator.pri (который в плагине)
LIBS *= -L$$LINK_LIBRARY_PATH \ # Qt Creator libraries
    -LC:/Qt/Qt5.8.0/Tools/QtCreator/bin

В итоге получаю кучу ошибок типа
plugin.cpp:-1: ошибка: undefined reference to `_imp___ZN4Core5ICore10mainWindowEv'

Причем, я уже делал плагин для Qt Creator 3.6 (не 3.8 как раньше написал)
У меня и сам Creator нормально компилировался и запускался и плагин под него вставал.
А сейчас засада какая-то.
Может кто-нибудь меня направит?
« Последнее редактирование: Февраль 16, 2017, 16:27 от GraninDm » Записан
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  

Страница сгенерирована за 0.048 секунд. Запросов: 22.