Russian Qt Forum
Декабрь 04, 2023, 09:17 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: [1]   Вниз
  Печать  
Автор Тема: Совместимы ли компоненты для создания Android приложения?  (Прочитано 2887 раз)
Гурман
Гуру общения
******
Offline Offline

Сообщений: 1442

Qt 2.2, 3.3, 4.5, 4,7, 4.8, 5.3, 5.6, 5.9, 5.12


Просмотр профиля
« : Июль 26, 2016, 20:37 »

Возникла необходимость в виндозе сделать приложение для Android, раньше этим не занимался. Первый вопрос - совместимы ли те компоненты, которые последние сейчас лежат на сайтах? То есть, если я скачаю:

- Android Studio 2.1
- Android NDK r12b
- Java SE Development Kit 7
- Apache Ant 1.9.7
- Qt 5.7
- и у меня уже установлен MinGW 4.8

будет ли весь этот зоопарк нормально друг с другом работать? Либо для надежности надо найти совместимые версии? Какие?

Планшет с ПК нормально управляется, то есть, USB драйвер есть, ADB есть версия 1.0.26, проверен.
Записан

2^7-1 == 127, задумайтесь...
LynXzp
Гость
« Ответ #1 : Ноябрь 25, 2016, 15:45 »

Да, ответ вовсе не вовремя. Скорее для тех кто еще сюда зайдет.

Похоже что совместимы. Мне совместимость очень понравилась, на днях написал свою первую программу в Qt под Linux для работы с COM портом, перекомпилировал в Windows - все заработало без единой правки (правда не очень понравилось что для создания exe-шника нужен сам Windows и установленный QtCreator в нем, но не беда.) Аналогично с Android - просто установил что надо и скомпилил - есть готовый apk (на отладку и симулятор забил), вот только одно но, даже два - для android нужно еще запрашивать разрешения, это надо какой-то манифест пилить и в моем случае была проблема с COM портом - в андроиде нельзя взять и просто поставить драйвера на USB<->RS232.

В остальном - программа заработала - всякие кнопочки фурычат. Жалко что до ума не довел, но это не нужно по ТЗ так что забил. (По ТЗ нужно приложение под Windows, решил вот сползти с Embarcadero, Qt прекрасная замена.)
Записан
Гурман
Гуру общения
******
Offline Offline

Сообщений: 1442

Qt 2.2, 3.3, 4.5, 4,7, 4.8, 5.3, 5.6, 5.9, 5.12


Просмотр профиля
« Ответ #2 : Ноябрь 26, 2016, 17:43 »

Давно работает всё... Правда с Qt 5.6.1.
Записан

2^7-1 == 127, задумайтесь...
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  


Страница сгенерирована за 0.048 секунд. Запросов: 22.