Russian Qt Forum
Май 23, 2024, 18:23 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: 1 [2]   Вниз
  Печать  
Автор Тема: qt6+QtCreator12 - не работает qDebug()  (Прочитано 2782 раз)
kambala
Джедай : наставник для всех
*******
Offline Offline

Сообщений: 4732



Просмотр профиля WWW
« Ответ #15 : Март 18, 2024, 10:48 »

у меня подозрение, что в исходной программе дело в том, что идет вывод кириллическких символов. У тебя случайно не выставлены какие-нить странные переменные среды, отвечающие за кодировку? В норме должно быть LC_ALL=en_US.UTF-8 / LANG=en_US.UTF-8 / LC_CTYPE=UTF-8 (это я со своей макос взял, но под линуксом вроде такие же)

так а если запустить ту исходную программу в терминале, что-то выводит?
Записан

Изучением C++ вымощена дорога в Qt.

UTF-8 has been around since 1993 and Unicode 2.0 since 1996; if you have created any 8-bit character content since 1996 in anything other than UTF-8, then I hate you. © Matt Gallagher
mokynis
Самовар
**
Offline Offline

Сообщений: 176


Просмотр профиля
« Ответ #16 : Март 22, 2024, 11:02 »

костыль:
чтобы qDebug выводил информацию хотя бы в терминал, в
Проекты-(сбоку)Сборка и запуск-Запустить-(основное окно)Запустить-Запускать в терминале (поставить галочку)
Записан

QT4, Qt5, Qt6 Debian, ArchLinux
Страниц: 1 [2]   Вверх
  Печать  
 
Перейти в:  


Страница сгенерирована за 0.044 секунд. Запросов: 22.