Russian Qt Forum
Декабрь 10, 2018, 19:39 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: [1]   Вниз
  Печать  
Автор Тема: C++11 как обязательное требование  (Прочитано 717 раз)
DarkHobbit
Чайник
*
Offline Offline

Сообщений: 77


Просмотр профиля
« : Январь 08, 2018, 11:07 »

Попытался собрать Qt 5.10 в статике старенькой версией MinGW (до этого успешно собирал 4.8.6). Получил ругань на неопознанную опцию -std=c++11.
В связи с этим вопросы:
  • является ли компилятор с поддержкой C++11 обязательным требованием для сборки современных версий Qt, или это можно как-то обойти в настройках?
  • если да - то начиная с какой версии Qt поддержка C++11 стала обязательной?
Нет, у меня нет принципиальной фобии по отношению к C++11. И на той системе, где я сейчас нахожусь, я, скорее всего, просто обновлю компилятор. Просто хочется нащупать границу: что я мог бы собрать компилятором без поддержки оного.
Записан

Мои проекты на Qt: DoubleContact, LInvert
__Heaven__
Джедай : наставник для всех
*******
Offline Offline

Сообщений: 2054



Просмотр профиля
« Ответ #1 : Январь 08, 2018, 13:36 »

5.7
https://wiki.qt.io/New_Features_in_Qt_5.7
Записан
DarkHobbit
Чайник
*
Offline Offline

Сообщений: 77


Просмотр профиля
« Ответ #2 : Январь 09, 2018, 07:58 »

Исчерпывающий ответ.
Записан

Мои проекты на Qt: DoubleContact, LInvert
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  

Страница сгенерирована за 0.209 секунд. Запросов: 22.