Russian Qt Forum
Апрель 20, 2024, 01:49 *
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?

Войти
 
  Начало   Форум  WIKI (Вики)FAQ Помощь Поиск Войти Регистрация  

Страниц: [1]   Вниз
  Печать  
Автор Тема: Проблема со звуком  (Прочитано 4411 раз)
klon4uk
Гость
« : Июль 23, 2012, 10:29 »

есть плата imx53
с помощью приложения madplay на плате играются мп3шки
в qt приложении не играються

 incommingSoundFile = settings->value("sounds/incomming", "/opt/linsys/panel/incomming.mp3").toString();
    if(!QFile::exists(incommingSoundFile))
    {
        qDebug() << "Incomming sound file not found: " << incommingSoundFile;
    }
    else
    {
#ifdef PHONON
        incommingSound = new Phonon::MediaObject(this);
        connect(incommingSound,SIGNAL(aboutToFinish()),this,SLOT(incommingSoundLoop()));
        Phonon::createPath(incommingSound,output);
#else
        incommingSound = new QSound(incommingSoundFile);
        incommingSound->setLoops(-1);
#endif

и вот что выдает на выходе:
(<unknown>:1113): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
Incomming sound file not found:  ""

напрягает последняя строка в которой даже не указываеться  путь по умолчанию..
прошу помощи разобраться с этой проблемой либо указать какие способы ещё можно использовать для подключения звука.
Записан
Bepec
Гость
« Ответ #1 : Июль 23, 2012, 10:36 »

Тебе ясно говорят - нет там у тебя файлика Улыбающийся Проверяй пути. Смотри куда утыкается.

PS не вижу я в коде запуска проигрывания кстате Веселый
Записан
klon4uk
Гость
« Ответ #2 : Июль 23, 2012, 10:46 »

пути проверял много раз , все хорошо с путями)
ну я поидее привел кусок кода с инициализацией, до  этого на  x86 все прекрасно работало...
система сделана из билдрута, на ней кстати путь QSettings тоже изначально не завелся)
может  надо как  то  по особенному указывать путь ?
и судя по  этой строке  мне он  должен указать путь который не найден...
 qDebug() << "Incomming sound file not found: " << incommingSoundFile;
а выдает как будто incommingSoundFile пустой.
Записан
Bepec
Гость
« Ответ #3 : Июль 23, 2012, 10:50 »

Значит он и есть пустой. Ради интереса проинициализируйте его в самом начале после чтения QSettings.
Видимо он пустоту оттуда читает и свято уверен, что это она и есть Улыбающийся
Записан
klon4uk
Гость
« Ответ #4 : Июль 23, 2012, 10:57 »

убрал файл настроек полностью
насколько я знаю в данной строке я по умолчанию задал  параметр
incommingSoundFile = settings->value("sounds/incomming", "/opt/linsys/panel/incomming.mp3").toString();
поидее он должен был бы выводить следующее :
Incomming sound file not found:  "/opt/linsys/panel/incomming.mp3"
а щас он выводит как будто там ничего нет О,о
Записан
klon4uk
Гость
« Ответ #5 : Июль 23, 2012, 13:25 »

блин вроде делал ребилд а его не было... Смеющийся
удалил все папку - все поехало...
опять проблемы qsettings почему то не хочет подхватывать...
дефолтный щас подхватываеться...
но звука нет, звук идет через phonon...
программа не моя, сказали только перенести на arm xD
(<unknown>:1385): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed
интересно как это победить ?
Записан
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  


Страница сгенерирована за 0.043 секунд. Запросов: 20.